Получитьформу по причине интерактивные операции недоступны

Получитьформу по причине интерактивные операции недоступны

Возвращает форму по имени

Синтаксис

Функция ПолучитьФорму() имеет следующий синтаксис:

А также альтернативный англоязычный синтаксис:

Параметры

Описание параметров процедуры ПолучитьФорму() :

Имя параметра Тип
Описание
ИмяФормы Строка
Имя формы, образованное как полный путь к объекту Форма в дереве метаданных (например, «Справочник.Сотрудники.Форма.ФормаОбъекта», «ОбщаяФорма.ФормаВопроса») или как полный путь к прикладному объекту, дополненный именем формы по умолчанию (например, «Справочник.Сотрудники.ФормаОбъекта»). Поддерживаются следующие формы по умолчанию:
  • ФормаОбъекта (ObjectForm) — форма объекта по умолчанию;
  • ФормаГруппы (FolderForm) — форма группы по умолчанию;
  • ФормаЗаписи (RecordForm) — форма записи регистра по умолчанию;
  • ФормаСписка (ListForm) — форма списка по умолчанию;
  • ФормаВыбора (ChoiceForm) — форма выбора по умолчанию;
  • ФормаВыбораГруппы (FolderChoiceForm) — форма выбора группы по умолчанию;
  • ФормаКонстант (ConstantsForm) — форма констант по умолчанию;
  • Форма (Form) — форма отчета и обработки по умолчанию;
  • ФормаНастроек (SettingsForm) — форма настроек отчета по умолчанию;
  • ФормаЗагрузки (LoadForm) — форма загрузки настроек;
  • ФормаСохранения (SaveForm) — форма сохранения настроек;
Параметры (необязательный) Структура Параметры формы. Ключ структуры — имя параметра, а значение — значение параметра формы Владелец (необязательный) ВладелецФормы Форма или элемент управления формы. Уникальность (необязательный) Произвольный Ключ уникальности формы. В данном параметре может быть задан некоторый ключ, значение которого будет использоваться для поиска уже открытых форм. Если будет найдена форма с таким же ключом уникальности, вместо открытия новой формы будет активизирована найденная форма Окно (необязательный) ОкноКлиентскогоПриложения Окно приложения, в котором будет открыта форма. Окном может быть только основное окно приложения или вспомогательное окно формы.

Применимо только для управляемой формы.

НавигационнаяСсылка (необязательный) Строка; Неопределено Если содержит значение, отличное от Неопределено , то это значение присваивается свойству НавигационнаяСсылка формы, полученной в результате вызова данного метода, и свойство АвтоНавигационнаяСсылка этой формы устанавливается в Ложь. Значение по умолчанию: Неопределено .

Применимо только для управляемой формы.

Жирным шрифтом выделены обязательные параметры

Возвращаемое значение

Описание

Функция ПолучитьФорму() получает форму по имени и возвращает ее. Перед этим осуществляется поиск ранее открытой формы того же типа и совпадающими параметрами: значениям ключевых параметров формы, владельца формы, пользовательского ключа уникальности. Для форм ФормаОбъекта , ФормаЗаписи , ФормаНабораЗаписей , ФормаКонстант при поиске ранее открытых форм, владелец не учитывается.

Доступность

Тонкий клиент, веб-клиент, мобильный клиент, толстый клиент, мобильное приложение(клиент).

Пример использования

Пример кода с использованием процедуры ПолучитьФорму() :

Область применения: управляемое приложение, мобильное приложение.

1. Для открытия форм следует применять метод глобального контекста ОткрытьФорму (при использовании версии платформы 1С:Предприятие 8.2 и более ранних версий — также ОткрытьФормуМодально ). Применение альтернативного способа, с получением формы и ее последующим открытием с помощью метода ПолучитьФорму , не рекомендуется.

Читайте также:  Расшифровка маркировки телевизоров dexp

Рекомендация обусловлена соображениями

  • повышения устойчивости кода, работающего с формой, за счет разделения программного интерфейса для работы с формой и деталей ее внутренней реализации,
  • а также сохранения единой стилистики кода прикладных решений.

Кроме того, применение глобального метода ОткрытьФорму гарантирует выполнение инициализации формы на сервере в обработчике ПриСозданииНаСервере . Этот подход помогает сосредоточить весь код инициализации формы в одном месте и исключает "случайное" обращение к серверу, связанное с инициализацией формы, между строками кода

2. В случаях когда форма требует параметризации при открытии, все ее параметры следует указывать в наборе параметров формы. Таким образом, набор параметров формы декларативно описывает возможности формы по ее параметризации.

Параметры формы из этого набора могут быть указаны в вызывающем коде при открытии формы ( ОткрытьФорму ).

3. Не следует применять другие способы параметризации формы при открытии. Например, нужно избегать обращения к методам и свойствам формы после ее открытия.
Например, вместо

МояФорма = Форма.ОткрытьФорму("ОбщаяФорма.ПутеводительПоСистеме");
МояФорма.Элементы.ГруппаШаг.ТекущаяСтраница = МойФорма.Элементы.ГруппаШаг.Страницы.Приветствие;

следует по той же причине использовать параметры формы:

ОткрытьФорму("ОбщаяФорма.ПутеводительПоСистеме", Новый Структура("РежимОткрытия", "Приветствие"));

4. Для получения результата работы формы, вместо непосредственного обращения к элементам и реквизитам формы

ФормаВопроса = ПолучитьФорму("ОбщаяФорма.ФормаВопроса");
ФормаВопроса.ОткрытьМодально();
Если ФормаВопроса.БольшеНеПоказыватьНапоминание Тогда
// …

следует использовать процедуры-обработчики оповещений, которые будут вызваны при завершении работы пользователя с формой:

Оповещение = Новый ОписаниеОповещения("БольшеНеПоказыватьНапоминаниеЗавершение", ЭтотОбъект);
ОткрытьФорму("ОбщаяФорма.ФормаВопроса". Оповещение, РежимОткрытияОкнаФормы.БлокироватьВеcьИнтерфейс);
.

&НаКлиенте
Процедура БольшеНеПоказыватьНапоминаниеЗавершение(БольшеНеПоказыватьНапоминание, Параметры) Экспорт

Если БольшеНеПоказыватьНапоминание = Неопределено Тогда
Возврат;
КонецЕсли;

Если БольшеНеПоказыватьНапоминание Тогда
// …

При этом возвращаемое значение формы формируется в коде модуля формы с помощью метода формы Закрыть .

5. Другие ограничения:

  • Обработчик события формы ПриОткрытии не должен содержать код по открытию какой-либо другой формы, так как это может привести к нарушению порядка отображения окон. В этом случае рекомендуется использовать обработчик ожидания на короткий интервал или открывать другие формы интерактивно, например, по нажатию на кнопку.
  • Не рекомендуется выполнять программное открытие и закрытие формы в одном обработчике. Такие действия должны быть разнесены по времени. Например, закрытие формы можно выполнять в обработчике ожидания.
  • При использовании в конфигурации Библиотека стандартных подсистем и разработке форм (рабочих мест), предназначенных только для внешних пользователей, следует явно блокировать открытие таких форм в сеансах "обычных" пользователей. Для этого следует устанавливать параметр Отказ при создании формы на сервере с помощью функции ЭтоСеансВнешнегоПользователя общего модуля Пользователи или ПользователиКлиент :

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)

Читайте также:  Пользователь занят что это значит

Если Не ПользователиКлиентСервер.ЭтоСеансВнешнегоПользователя() Тогда
Отказ = Истина;
Возврат;
КонецЕсли;

КонецПроцедуры

6. Следующие виды форм должны быть всегда доступны пользователю в режиме 1С:Предприятия из меню "Все функции" вне зависимости от того, размещены ли соответствующие объекты в командном интерфейсе приложения или нет:

Программное открытие форм в управляемом приложении 1С значительно отличается от их открытия в обычном приложении. Рассмотрим для начала старый метод. Он заключается в получении формы и ее последующем открытии в обычном или модальном режиме (при открытии в модальном режиме форма блокирует работу программы).

Это самый медленный метод открытия форм. Тем не менее, он позволяет программно обработать форму перед открытием. Для обработки код нужно немного изменить:

Надо учитывать, что при получении формы будет выполняться еще процедура события ПриСозданииНаСервере.

Рассмотрим другие методы, которые позволяют открывать формы в управляемом приложении 1С быстрее и удобнее. В зависимости от конкретной ситуации могут использоваться разные методы.

1. Как открыть форму объекта в управляемом приложении, если есть ссылка на него.

В этом случае все предельно просто.

2. Как открыть форму выбора и получить потом выбранное значение.

Для этого существует функция ВвестиЗначение(). У функции 3 параметра:

  • Переменная, в которую будет записано выбранное значение;
  • Подсказка, которая будет отображена в окне выбора;
  • Описание типов выбираемых значений. Может быть несколько типов, тогда перед выбором конкретного значения будет предложено выбрать тип.

В результате выполнения функции откроется форма выбора по умолчанию для объекта указанного типа.

Перем Значение ;
Массив = новый массив ;
Массив . Добавить ( Тип ( "СправочникСсылка.Номенклатура" ) ) ;
Массив . Добавить ( Тип ( "СправочникСсылка.Контрагенты" ) ) ;

ОписаниеТипов = новый ОписаниеТипов ( Массив ) ;

Рез = ВвестиЗначение ( Значение , "Подсказка" , ОписаниеТипов ) ;

Предыдущие способы позволяли открывать только формы, установленные для объектов по умолчанию (форму объекта или форму выбора). Если нужно открыть произвольную форму, то можно воспользоваться функцией ОткрытьФорму().

Эта функция имеет довольно много параметров. Рассмотрим некоторые из них:

  • Имя формы — тут можно выбрать либо одну из стандартных форм объекта, например, ФормаВыбора или ФормаСписка. Или конкретную, созданную разработчиками форму.
  • Параметры — позволяет передать в форму в виде структуры некоторые параметры перед ее открытием, тем самым определив выводимые данные. Параметры могут представлять собой любые данные, которые можно передавать с клиента на сервер. Переданные при открытии формы параметры можно обработать в процедуре ПриСозданииНаСервере() у открываемой формы.
  • Режим открытия формы — имеет 3 варианта: независимый, блокировать весь интерфейс, блокировать форму владельца.

Рассмотрим, как применяется функция ОткрытьФорму() в различных ситуациях.

Читайте также:  Почему не загружается музыка купленная в itunes

3. Как открыть форму существующего объекта

У каждой формы есть один ключевой реквизит. Он выделен жирным в списке реквизитов формы и обычно называется Объект у форм элементов справочников, документов. У других объектов название может быть другим. Для открытия формы существующего объекта нужно передать в открываемую форму параметр Ключ со значением в виде ссылки на объект.

&НаКлиенте
Процедура Команда 1 ( Команда )
Параметр = новый структура ;
Параметр . Вставить ( "Ключ" , НайтиС ( ) ) ;
ОткрытьФорму ( "Справочник.Контрагенты.ФормаОбъекта" , Параметр ) ;
КонецПроцедуры

&НаСервере
Функция НайтиС ( ) ;
Возврат Справочники . Контрагенты . НайтиПоРеквизиту ( "ИНН" , "745107734623" )
КонецФункции

4. Как открыть форму нового объекта

Тут подойдет просто функция ОткрытьФорму() без всяких параметров.

5. Как открыть форму нового объекта и заполнить ее на основании чего-либо

Нужно передать параметр Основание, значением которого будет являться ссылка на объект-основание заполнения. При этом будет запущена процедура ОбработкаЗаполнения().

В этом примере будет создан документ Реализация товаров и услуг и заполнен на основании счета на оплату покупателю, ссылка на который была передана.

6. Как открыть форму и задать на ней отбор

Отбор на формах 1С может быть простым и сложным. Простой отбор предусматривает выражения типа Организация = ООО «Рога и копыта». Сложный отбор предполагает и другие типы сравнения, например, В списке. В данной статье рассмотрим организацию простого отбора, а сложному будет посвящена отдельная статья.

Чтобы организовать простой отбор, нужно передать в открываемую форму параметр с ключом Отбор, значением будет являться структура, в которой ключ — имя поля динамического списка, а значение — искомые данные.

Например, откроем форму списка справочника НомераГТД и сделаем там отбор по владельцу — элементу справочника Номенклатура.

Отбор = новый Структура ;
Отбор . Вставить ( "Владелец" , СсылкаНаНоменклатуру ) ;

Параметр . Вставить ( "Отбор" , Отбор ) ;

ОткрытьФорму ( "Справочник.НомераГТД.ФормаСписка" , Параметр ) ;
КонецПроцедуры

7. Как открыть форму записи регистра сведений

Для этого понадобится ключ записи регистра сведений.

Ключ записи — это значения всех измерений и период (если регистр периодический). То есть ключ записи — это параметры, по которым можно однозначно идентифицировать запись.

Алгоритм открытия следующий:

  1. Заносим в структуру данные ключа записи с необходимыми значениями.
  2. Помещаем полученную структуру в массив.
  3. Из массива создаем ключ записи.
  4. Передаем в открываемую форму параметр Ключ с ключом записи из п.3 в качестве значения.

ПараметрыКлюча = новый Структура ;
ПараметрыКлюча . Вставить ( "Номенклатура" , СсылкаНаНоменклатуру ) ;
ПараметрыКлюча . Вставить ( "ТипЦены" , СсылкаНаТипЦен ) ;
ПараметрыКлюча . Вставить ( "Период" , Дата ) ;

МассивКлюча = Новый Массив ;
МассивКлюча . Добавить ( ПараметрыКлюча ) ;

КлючЗаписи = Новый ( "РегистрСведенийКлючЗаписи.ЦеныНоменклатуры" , МассивКлюча ) ;

Параметр . Вставить ( "Ключ" , КлючЗаписи ) ;

ОткрытьФорму ( "РегистрСведений.ЦеныНоменклатуры.ФормаЗаписи" , Параметр ) ;
КонецПроцедуры

Ссылка на основную публикацию
Поиск картинки по картинке яндекс с телефона
Читайте, как работает поиск по фото с телефона. С тех пор как телефоны оснастили качественными камерами, изображения стали одним из...
Папка mats на диске c
Свободное пространство диска С в процессе эксплуатации Windows постоянно сокращается. В независимости от действий пользователя — хочет он того или...
Периодичность по позиции регистратора
Цель работы 1.1 Научиться создавать и работать с объектом «Регистр сведений», связывать его с документами. Краткие теоретические сведения Объект конфигурации...
Полировка стекла apple watch
Умные электронные носимые устройства плотно входят в нашу жизнь. Кроме основной функции, доступной классическим часам - проверки текущего времени, даты...
Adblock detector