Эксель округление в меньшую сторону

Эксель округление в меньшую сторону

Округление чисел в Excel нужно для удобного форматирования, прогнозирования и коммуникации.

Существует множество способов округления, такие как округление до целого числа, округление в большую сторону, округление в меньшую сторону и т.д. В Excel мы можем округлять числа с помощью функций. Их мы и рассмотрим в этой статье.

Округление чисел в Excel с помощью изменения формата ячейки

Если вы хотите округлить числа исключительно с целью презентации, вы можете изменить формат ячейки, выполнив следующие шаги:

  • Кликнуть по ячейке с числовым значением;
  • Открыть меню форматирования ячейки с помощью сочетания клавиш CTRL+1 или кликнуть по ячейке правой кнопкой и в выпадающем списке выбрать пункт “ Формат ячеек “;
  • В всплывающем окне “ Формат ячеек ” перейти на вкладку “ Число “;
  • В разделе “ Числовые форматы ” кликнуть по пункту “ Числовой “;
  • В меню окна найти пункт “ Число десятичных знаков ” и указать точное количество знаков после запятой, которое вы хотите оставить;
  • Кликните по кнопке “ ОК ” для сохранения настроек форматирования.

Важно! Этот метод только визуально округляет число, не “отрезая” числа после запятой.

Округление в Excel с помощью функции ОКРУГЛ

Функция ОКРУГЛ часто используется в Excel для округления чисел. С ее помощью вы можете задать количество чисел после запятой.

Синтаксис

=ОКРУГЛ(число;число_разрядов)

Аргументы функции

  • число – числовое значение, которое вы хотите округлить;
  • число_разрядов – значение десятичного разряда, до которого вы хотите округлить первый аргумент функции.

Основы использования функции

  • если аргумент число_разрядовбольше “0”, то число округляется до указанного количества десятичных знаков. Например, =ОКРУГЛ(500,51;1) вернет “500.5”;
  • если аргумент число_разрядов равен “0”, то число округляется до ближайшего целого числа. Например, =ОКРУГЛ(500,51;0) вернет “501”;
  • если аргумент число_разрядовменьше “0”, то число округляется влево от десятичного значения. Например, =ОКРУГЛ(500,51;-1) вернет “501”.

Функция ОКРУГЛ работает на основе математического правила, по которому она определяет в большую или меньшую сторону следует округлить число:

  • Если число после запятой равно от 0 до 4, то округление будет произведено в меньшую сторону;
  • Если число после запятой равно от 5 до 9, то функция округлит в большую сторону.

На скриншоте ниже показаны примеры использования функции:

Округление в Excel в большую сторону с помощью функции ОКРУГЛВВЕРХ

Функция ОКРУГЛВВЕРХ округляет число в большую сторону, вне зависимости от того, какое число стоит после запятой.

Читайте также:  Бюджетные ноутбуки до 15000

Синтаксис

=ОКРУГЛВВЕРХ(число;число_разрядов)

Аргументы функции

  • число – числовое значение, которое вы хотите округлить;
  • число_разрядов – значение десятичного разряда, до которого вы хотите округлить первый аргумент функции.

Примеры использования функции ниже:

Округление в Excel в меньшую сторону с помощью функции ОКРУГЛВНИЗ

Функция ОКРУГЛВНИЗ округляет число в меньшую сторону, вне зависимости от того, какое число стоит после запятой.

Синтаксис

=ОКРУГЛВВНИЗ(число;число_разрядов)

Аргументы функции

  • число – числовое значение, которое вы хотите округлить;
  • число_разрядов – значение десятичного разряда, до которого вы хотите округлить первый аргумент функции.

На скриншоте ниже примеры использования функции:

Редактор таблиц Microsoft Excel широко применяется для выполнения разного рода вычислений. В зависимости от того, какая именно задача стоит перед пользователем, меняются как условия выполнения задачи, так и требования к получаемому результату. Как известно, выполняя расчёты, очень часто в результате получаются дробные, нецелые значения, что в одних случаях хорошо, а в других, наоборот, неудобно. В этой статье подробно рассмотрим, как округлить или убрать округление чисел в Excel. Давайте разбираться. Поехали!

Для удаления дробных значений применяют специальные формулы

О существовании специальной функции округления в Экселе знают далеко не все пользователи. Случается, что некоторые из них ошибочно принимают формат значений, то есть отображаемое количество знаков после запятой, за округление. Далее в статье разберёмся, что к чему и как всё делается.

Для начала отметим, что функция «Формат числа» применяется в случаях, когда вид числа необходимо сделать более удобным для чтения. Кликните правой кнопкой мыши и выберите в списке пункт «Формат ячеек». На вкладке «Числовой» установите количество видимых знаков в соответствующем поле.

Но в Excel реализована отдельная функция, позволяющая выполнять настоящее округление по математическим правилам. Для этого вам понадобится поработать с полем для формул. Например, вам нужно округлить значение, содержащееся в ячейке с адресом A2 так, чтобы после запятой остался только один знак. В таком случае функция будет иметь такой вид (без кавычек): «=ОКРУГЛ(A2;1)».

Принцип прост и понятен. Вместо адреса ячейки вы можете сразу указать само число. Бывают случаи, когда возникает необходимость округлить до тысяч, миллионов и больше. Например, если нужно сделать из 233123 — 233000. Как же быть в таком случае? Принцип тут такой же, как было описано выше, с той разницей, что цифру, отвечающую за количество разделов, которые необходимо округлить, нужно написать со знаком «-» (минус). Выглядит это так: «=ОКРУГЛ(233123;-3)». В результате вы получите число 233000.

Читайте также:  Моргает caps lock на ноутбуке hp

Если требуется округлить число в меньшую либо в большую сторону (без учёта того, к какой стороне ближе), то воспользуйтесь функциями «ОКРУГЛВНИЗ» и «ОКРУГЛВВЕРХ». Вызовите окно «Вставка функции». В пункте «Категория» выберите «Математические» и в списке ниже вы найдёте «ОКРУГЛВНИЗ» и «ОКРУГЛВВЕРХ».

Ещё в Excel реализована очень полезная функция «ОКРУГЛТ». Её идея в том, что она позволяет выполнить округление до требуемого разряда и кратности. Принцип такой же, как и в предыдущих случаях, только вместо количества разделов указывается цифра, на которую будет заканчиваться полученное число.

В последних версиях программы реализованы функции «ОКРВВЕРХ.МАТ» и «ОКРВНИЗ.МАТ». Они могут пригодиться, если нужно принудительно выполнить округление в какую-либо сторону с указанной точностью.

Как вариант, решить проблему можно при помощи функции «ЦЕЛОЕ», принцип которой заключается в том, что дробная часть просто отбрасывается, округляя вниз.

Иногда программа автоматически округляет полученные значения. Отключить это не получится, но исправить ситуацию можно при помощи кнопки «Увеличить разрядность». Кликайте по ней, пока значение не приобретёт нужный вам вид.

Теперь, когда вы разбираетесь, как выполнять округление числа, вам будет проще выполнять ряд задач в программе. Кроме того, эти навыки помогут вам и в решении повседневных вопросов, связанных с расчётами.

Если Excel округляет длинные числа

Если вы вставите в числовую ячейку длинное число с более, чем 15 разрядов, то Excel округлит его и выдаст нечто совсем непригодное. Например, число 893800399000003570 он покажет в виде 8,938E+17, а если по нему кликнуть, покажет его, как 893800399000003000. Здесь мы видим потерю последних трёх разрядов, что совершенно неприемлемо.

Решить проблему можно, если изменить формат ячейки или колонки с числового на текстовый. Тогда вставляемое число любой разрядности не будет преобразовываться. Также можно вставить его в числовую ячейку, если перед числом использовать знак одинарных кавычек.

Однако при преобразовании таких строчных записей в число Excel снова округляет все разряды больше 15-ти. Поэтому такой способ подходит лишь для представления больших чисел в таблице, а для вычислений они всё равно должны преобразовываться с потерями. Сделать с этим ничего нельзя – Excel так устроен, и 15 разрядов – предельная его точность, с которой можно записывать числа в таблице.

Читайте также:  Заявка на восстановление страницы вк отклонена

Пишите в комментариях были ли статья полезной для вас и продолжайте совершенствовать навыки работы в Microsoft Excel.

Стандартная функция

Дробные числа в электронных таблицах Excel можно выводить на экран с разной степенью точности:

  • самый простой способ – на вкладке «Главная» нажимаем кнопки «Увеличить разрядность» или «Уменьшить разрядность»;
  • щелкаем правой кнопкой мыши по ячейке, в раскрывшемся меню выбираем «Формат ячеек…», далее вкладка «Число», выбираем формат «Числовой», определяем, сколько будет десятичных знаков после запятой (по умолчанию предлагается 2 знака);
  • щелкаем ячейку, на вкладке «Главная» выбираем «Числовой», либо идем на «Другие числовые форматы…» и там настраиваем.

Вот как выглядит дробь 0,129, если менять количество десятичных знаков после запятой в формате ячейки:

Обратите внимание, в A1,A2,A3 записано одно и то же значение, меняется только форма представления. При дальнейших расчетах будет использоваться не величина, видимая на экране, а исходная. Начинающего пользователя электронных таблиц это может слегка запутать. Чтобы реально изменить значение, необходимо использовать специальные функции, их в Excel несколько.

Формула округление

Одна из часто применяемых функций округления – ОКРУГЛ. Она работает по стандартным математическим правилам. Выбираем ячейку, щелкаем значок «Вставить функцию», категория «Математические», находим ОКРУГЛ.

Определяем аргументы, их два – сама дробь и количество разрядов. Щелкаем «ОК» и смотрим, что получилось.

К примеру, выражение =ОКРУГЛ(0,129;1) даст результат 0,1. Нулевое количество разрядов позволяет избавляться от дробной части. Выбор отрицательного количества разрядов позволяет округлять целую часть до десятков, сотен и так далее. Например, выражение =ОКРУГЛ(5,129;-1) даст 10.

Округляем в большую или меньшую сторону

В Excel представлены и другие средства, позволяющие работать с десятичными дробями. Одно из них – ОКРУГЛВВЕРХ, выдает самое близкое число, большее по модулю. Например, выражение =ОКРУГЛВВЕРХ(-10,2;0) даст -11. Количество разрядов здесь 0, значит, получим целое значение. Ближайшее целое, большее по модулю, – как раз -11. Пример использования:

ОКРУГЛВНИЗ аналогична предыдущей функции, но выдает ближайшее значение, меньшее по модулю. Различие в работе вышеописанных средств видно из примеров:

Ссылка на основную публикацию
Чтобы продолжить установку используйте параметр загрузки драйвера
Приветствую всех посетителей моего портала! Драйвера запоминающего устройства для установки – стандартное ПО, в использовании которого редко возникает необходимость. «Драйвер...
Что дает geforce experience
The server encountered an internal error or misconfiguration and was unable to complete your request. Please contact the server administrator...
Что дает перепрошивка смартфона
К моему большому сожалению, такой огромный пласт гик-культуры, как прошивка смартфонов, очень мало обозревается на IT-сайтах. Но бьюсь об заклад,...
Чтобы установить в системе новый язык нужно
Правильный ответ на вопрос: создать запись языка на странице «Языки», загрузить языковые файлы для данного языка через систему обновлений Другие...
Adblock detector